Commandes du menu

Le menu « Actions »
Le menu « Annuler »
Le menu « Paquet »
Le menu « Solutions »
Le menu « Rechercher »
Le menu « Options »
Le menu « Vues »
Le menu « Aide »

Le menu « Actions »

Figure 2.1. Commandes disponibles dans le menu Actions

CommandeDescription 
Actions → Installer/enlever des paquets (g) Afficher un aperçu d'installation, s'il n'y en a pas de visible. Sinon lancer un processus d'installation, décrit dans la section intitulée « Télécharger, installer et supprimer des paquets ».
Actions → Mettre à jour les listes de paquets (u) Mettre à jour la liste des paquets.
Actions → Marquer comme étant susceptible de mise à jour (U) Marquer tous les paquets susceptibles de l'être comme devant être mis à jour, à l'exception de ceux qui sont gelés ou interdits de mise à jour.
Actions → Oublier quels paquets sont nouveaux (f) Oublier quels paquets sont « nouveaux » (c'est-à-dire vider l'arborescence « Nouveaux paquets »).
Actions → Annuler les actions en attente Annuler toutes les actions en attente dans cette session (ce qui inclut les installations, suppressions, mises à jour, gels, marquage des paquets automatiquement installés…). Cela est pratiquement équivalent au redémarrage du programme.
Actions → Nettoyer le cache des paquets Supprimer toutes les archives de paquets qui ont été téléchargées par aptitude [a].
Actions → Enlever les fichiers périmés Supprimer toutes les archives de paquets qui ont été téléchargées par aptitude[a] et qui ne sont plus disponibles dans les archives Debian. On peut supposer que ce sont des paquets obsolètes et qui peuvent être supprimés pour libérer de l'espace disque sans que cela ne nécessite de téléchargements inutiles par ailleurs.
Actions → Jouer au démineur Lancer le démineur, comme cela est décrit dans la section intitulée « Jouer au démineur ».
Actions → Devenir administrateur Continuer à travailler en tant qu'utilisateur root. Voir la section intitulée « Devenir administrateur (« root ») ».
Actions → Quitter (Q) Quitter aptitude et enregistrer les modifications des états des paquets.

[a] ou tout autre utilitaire apt.


Le menu « Annuler »

Figure 2.2. Commandes disponibles dans le menu Annuler

CommandeDescription 
Annuler → Annuler (Contrôle+u) Annuler, un à un, les effets du dernier changement effectué sur l'état d'un paquet avec la possibilité de remonter jusqu'à la dernière fois que le programme a été démarré, que la liste des paquets a été mise à jour ou qu'un processus d'installation a été lancé.

Le menu « Paquet »

Figure 2.3. Commandes disponibles dans le menu Paquet

CommandeDescription 
Paquet → Installer (+) Marquer le paquet actuellement sélectionné pour installation.
Paquet → Réinstaller (+) Marquer le paquet actuellement sélectionné pour réinstallation.
Paquet → Supprimer (-) Marquer le paquet actuellement sélectionné pour suppression.
Paquet → Purger (_) Marquer le paquet actuellement sélectionné pour purge.
Paquet → Garder (:) Annuler toute installation, mise à jour ou suppression prévue pour le paquet actuellement sélectionné et retirer tout gel qui aurait été mis sur le paquet.
Paquet → Geler (=) Geler le paquet actuellement sélectionné.
Paquet → Marquer automatiquement (M) Marquer le paquet actuellement sélectionné comme étant un paquet « installé automatiquement ». Pour plus d'informations sur les paquets installés manuellement et automatiquement, consultez la section intitulée « Gérer les paquets automatiquement installés ».
Paquet → Marquer manuellement (m) Marquer le paquet actuellement sélectionné comme étant un paquet « installé manuellement ». Pour plus d'informations sur les paquets installés manuellement et automatiquement, consultez la section intitulée « Gérer les paquets automatiquement installés ».
Paquet → Interdire la version (F) Si un paquet qui peut être mis à jour est sélectionné, cela interdit sa mise à jour vers la version actuellement disponible uniquement. Si une version du paquet est sélectionnée, cela interdit au paquet d'être mis à jour vers cette version.
Paquet → Informations (entrée) Afficher un écran contenant des informations sur le paquet actuellement sélectionné, comme les paquets dont il dépend, les paquets qui en dépendent, et ses versions disponibles.
Paquet → Circuler cycliquement dans l'information sur les paquets (i) Lors du parcours de la liste des paquets, les informations peuvent être affichées cycliquement dans la zone d'informations (la moitié inférieure de l'écran). Cette zone d'information peut afficher la description longue des paquets sélectionnés (c'est le comportement par défaut), un résumé des dépendances liées à ce paquet, ou une analyse des paquets qui nécessitent ou suggèrent le paquet sélectionné.
Paquet → Liste des modifications (C) Affiche la liste des modifications du paquet Debian actuellement sélectionné. Pour voir les modifications d'une version particulière, sélectionnez cette version avant d'exécuter cette commande.

Le menu « Solutions »

Figure 2.4. Commandes disponibles dans le menu Solutions

CommandeDescription 
Solutions → Examiner la solution (e) Afficher une description détaillée de la suggestion actuelle (consultez la section intitulée « Résolution interactive des dépendances »).
Solutions → Appliquer la solution (!) Exécuter les actions actuellement suggérées.
Solutions → Solution suivante (.) Sélectionner la suggestion suivante.
Solutions → Solution précédente (,) Sélectionner la suggestion précédente.
Solutions → Première solution (<) Sélectionner la première suggestion.
Solutions → Dernière solution (>) Sélectionner la suggestion la plus récente (voir la section intitulée « Résolution interactive des dépendances »).
Solutions → Marquer comme rejeté (r) Lors de l'examen d'une solution, rejeter l'action actuellement sélectionnée et passer à l'action suivante (voir la section intitulée « Résolution interactive des dépendances »). Si l'action était dans l'état approuvé, son approbation est annulée.
Solutions → Marquer comme retenu (a) Lors de l'examen d'une solution, approuver l'action actuellement sélectionnée et passer à l'action suivante (voir la section intitulée « Résolution interactive des dépendances »). Si l'action était dans l'état rejeté, son rejet est annulé.
Solutions → Afficher la cible (entrée) Lors de l'examen d'une solution, afficher des informations détaillées sur le paquet touché par l'action actuellement sélectionnée (voir la section intitulée « Résolution interactive des dépendances »).
Solutions → Rejeter les non-respects de gels Rejeter (comme avec Solutions → Marquer comme rejeté (r)) toutes les actions qui pourraient casser le gel d'un paquet ou installer une version interdite. Ces actions sont rejetées par défaut, sauf si Aptitude::ProblemResolver::Allow-Break-Holds est positionnée à true, mais cette entrée de menu vous permet de les rejeter manuellement à tout moment.

Le menu « Rechercher »

Figure 2.5. Commandes disponibles dans le menu Rechercher

CommandeDescription 
Rechercher → Rechercher (/) Rechercher le paquet suivant dans la liste des paquets qui correspond au motif de recherche (voir la section intitulée « Motifs de recherche »).
Rechercher → Rechercher en arrière (\) Rechercher le paquet précédent dans la liste des paquets qui correspond au motif de recherche (voir la section intitulée « Motifs de recherche »).
Rechercher → Rechercher à nouveau (n) Répéter la dernière recherche.
Rechercher → Rechercher en arrière (N) Répéter la dernière commande, mais dans le sens inverse. Si la dernière commande Rechercher était Rechercher vers le haut, alors cela exécutera un Rechercher vers le bas, et vice versa.
Rechercher → Affichage restreint (l) Filtrer la liste de paquets en omettant tous les paquets qui ne correspondent pas au motif de recherche (voir la section intitulée « Motifs de recherche »).
Rechercher → Affichage complet Retirer le filtrage de la liste de paquets (tous les paquets sont affichés).
Rechercher → Rechercher les cassés (b) Rechercher le paquet cassé suivant. Cela revient à rechercher ?broken.

Le menu « Options »

Figure 2.6. Commandes disponibles dans le menu Options

CommandeDescription 
Options → Préférences Ouvrir une nouvelle vue dans laquelle les paramètres d'aptitude peuvent être modifiés. Les options de configuration sont affichées dans un arbre similaire à celui des paquets. Pour activer ou désactiver une option, sélectionnez-la et appuyez sur Espace ou Entrée. Les options de configuration sont sauvegardées dans le fichier ~/.aptitude/config immédiatement après avoir été sélectionnées.
Options → Revenir aux options par défaut Revenir aux options de configuration par défaut.

Le menu « Vues »

[Note]Note

Pour un aperçu du fonctionnement des vues, consultez la section intitulée « Travailler avec plusieurs vues ».

Figure 2.7. Commandes disponibles dans le menu Vues

CommandeDescription 
Vues → Suivant (F6) Aller à la vue active suivante.
Vues → Précédent (F7) Aller à la vue active précédente.
Vues → Fermer (q) Fermer la vue actuelle.
Vues → Nouvelle vue des paquets Créer une nouvelle vue de la liste des paquets.
Vues → Voir les recommandations Créer une vue qui affiche les paquets qui ne sont pas installés et qu'un paquet installé sur votre système recommande.
Vues → Nouvelle liste des paquets Créer une nouvelle vue de la liste des paquets dans laquelle les paquets ne sont pas triés.
Vues → Consultation par « Debtags » Créer une nouvelle vue de la liste des paquets dans laquelle les paquets sont rangés en fonction de leur entrée debtags.
Entrées supplémentaires D'autres entrées du menu apparaissent. Il s'agit des vues actuellement actives. Pour atteindre directement une vue, sélectionnez-la dans ce menu.

Le menu « Aide »

Figure 2.8. Commandes disponibles dans le menu Aide

CommandeDescription 
Aide → À propos Afficher des informations de copyright.
Aide → Aide (?) Afficher l'aide en ligne.
Aide → Manuel Utilisateur Afficher le manuel de l'utilisateur (ce document).
Aide → FAQ Afficher la FAQ d'aptitude.
Aide → Liste des modifications Afficher la liste des principales modifications apportées à aptitude.
Aide → Licence Afficher les termes de la licence sous laquelle vous pouvez copier, modifier et distribuer aptitude.